last modified: 2017-10-25

EMLyon logo corp

The screen shows a lot of white particles

pic 2

Explanation: your sketch was not loaded to the object yet.

Solution: make sur you got the sketch to load to your object.

You know it has loaded successfully when the red line in the Arduino go to "100%"

"fatal error: Adafruit_SSD1306.h: No such file or directory"

Solution:

  1. install the library from Sketch → Include Library → Manage Libraries: type SSD1306 in the search bar and find it.

In the list of SSD1306 Libraries, make sure you install the one by Adafruit, not Acrobotic.
  1. Import this lirary in your sketch via Sketch → Include Libraries → find it in the list!!

"cannot access COM1 / espcomm_open failed"

Solution:

if you are on a Mac:

  1. New / recent Mac only: make sure you installed this:

  1. Older Mac (Mac OS 10.12.6 or older): make sure you installed this instead:

  1. All Macs: in the Arduino IDE, with your sketch open, go to Tools and put your mouse above (don’t click!) Port:. Then select:

→ In the list of ports, select the one that has "/dev/cu.SLAB_USBtoUART" in the name

if you are on a PC:

→ In the list of ports, try selecting each port (COM1, COM17…​ you might have different ones) until the error disappears.

Upload complete but nothing on screen

Possible causes:

the wifi ssid is invalid: the name of the ssid you are using includes spaces or special characters (like: "my super wifi")*

→ Use a wifi ssid and passwords which are simpler (like: "mysuperwifi")

If you are on a Mac Computer, the adaptator for USB cables (white cable on the picture below) does not work:

pic 1

→ try changing the usb cable. Some cables don’t work.

The end

Find references for this lesson, and other lessons, here.

round portrait mini 150 This course is made by Clement Levallois.

Discover my other courses in data / tech for business: http://www.clementlevallois.net

Or get in touch via Twitter: @seinecle

site
    stats